Linux anchor 4.4.0-210-generic #242-Ubuntu SMP Fri Apr 16 09:57:56 UTC 2021 x86_64
Apache/2.4.18 (Ubuntu)
Server IP : 10.10.100.4 & Your IP : 216.73.217.150
Domains :
Cant Read [ /etc/named.conf ]
User : www-data
Terminal
Auto Root
Create File
Create Folder
Localroot Suggester
Backdoor Destroyer
Readme
/
etc /
rc0.d /
Delete
Unzip
Name
Size
Permission
Date
Action
K01apache-htcacheclean
2.16
KB
-rwxr-xr-x
2016-04-05 23:15
K01apache2
7.9
KB
-rwxr-xr-x
2016-04-05 23:15
K01atd
1.05
KB
-rwxr-xr-x
2015-12-06 16:45
K01irqbalance
2.32
KB
-rwxr-xr-x
2016-04-11 19:39
K01lvm2-lvmetad
571
B
-rwxr-xr-x
2015-10-30 18:33
K01lvm2-lvmpolld
586
B
-rwxr-xr-x
2015-10-30 18:33
K01lxcfs
2.32
KB
-rwxr-xr-x
2017-11-09 02:43
K01lxd
2.48
KB
-rwxr-xr-x
2016-10-13 16:04
K01mdadm
2.31
KB
-rwxr-xr-x
2017-10-09 15:47
K01open-iscsi
2.44
KB
-rwxr-xr-x
2016-03-29 19:32
K01open-vm-tools
1.8
KB
-rwxr-xr-x
2018-03-22 13:13
K01openvpn
10
KB
-rwxr-xr-x
2016-01-21 12:16
K01plymouth
1.33
KB
-rwxr-xr-x
2015-11-15 13:55
K01postfix
7.79
KB
-rwxr-xr-x
2017-10-25 14:50
K01resolvconf
4.05
KB
-rwxr-xr-x
2015-11-23 17:35
K01thermald
1.13
KB
-rwxr-xr-x
2016-01-29 10:57
K01unattended-upgrades
1.36
KB
-rwxr-xr-x
2017-04-20 17:16
K01unscd
3.58
KB
-rwxr-xr-x
2015-12-03 19:28
K01urandom
3.04
KB
-rwxr-xr-x
2016-01-19 19:33
K01uuidd
1.28
KB
-rwxr-xr-x
2016-05-27 01:30
K02dovecot
5.12
KB
-rwxr-xr-x
2016-03-19 00:29
K02iscsid
1.47
KB
-rwxr-xr-x
2016-03-29 19:32
K03mysql
5.48
KB
-rwxr-xr-x
2016-07-11 15:36
K04sendsigs
3.83
KB
-rwxr-xr-x
2016-01-19 19:33
K05rsyslog
2.73
KB
-rwxr-xr-x
2016-02-03 11:54
K06hwclock.sh
3.72
KB
-rwxr-xr-x
2016-03-12 16:14
K06umountnfs.sh
2.15
KB
-rwxr-xr-x
2016-01-19 19:33
K07networking
4.66
KB
-rwxr-xr-x
2015-07-19 23:45
K08umountfs
2.67
KB
-rwxr-xr-x
2016-01-19 19:33
K09cryptdisks
937
B
-rwxr-xr-x
2015-03-28 21:38
K10cryptdisks-early
896
B
-rwxr-xr-x
2015-03-28 21:38
K11umountroot
1.83
KB
-rwxr-xr-x
2016-01-19 19:33
K12mdadm-waitidle
1.17
KB
-rwxr-xr-x
2014-07-16 17:02
K13halt
1.3
KB
-rwxr-xr-x
2016-01-19 19:33
README
353
B
-rw-r--r--
2016-01-19 19:33
Save
Rename
#!/bin/sh # ### BEGIN INIT INFO # Provides: resolvconf # Required-Start: $local_fs # Required-Stop: $local_fs # X-Start-Before: networking ifupdown # Default-Start: S # Default-Stop: 0 6 # Short-Description: Nameserver information manager # Description: This service manages the list of nameserver addresses # used by the libc resolver and name service caches ### END INIT INFO # # This file is part of the resolvconf package. # # We really need "X-Stop-Before: networking ifupdown" too because # terminal ifdowns shouldn't update resolv.conf; # however there is unfortunately no such thing as "X-Stop-Before". # # This file is not used in Ubuntu. # # Don't use set -e; check return status instead. [ -x /sbin/resolvconf ] || exit 0 PATH=/sbin:/bin RUN_DIR=/run/resolvconf ENABLE_UPDATES_FLAGFILE="${RUN_DIR}/enable-updates" POSTPONED_UPDATE_FLAGFILE="${RUN_DIR}/postponed-update" . /lib/lsb/init-functions # Abort if Upstart is in use, as per Policy ยง9.11.1. case "$1" in start|restart|force-reload) init_is_upstart && exit 1 ;; stop) init_is_upstart && exit 0 ;; esac # $1 EXITSTATUS # [$2 MESSAGE] log_action_end_msg_and_exit() { log_action_end_msg "$1" ${2:+"$2"} exit $1 } create_runtime_directories() { umask 022 if [ ! -d "$RUN_DIR" ] ; then [ -L "$RUN_DIR" ] || log_action_end_msg_and_exit 1 "$RUN_DIR is neither a directory nor a symbolic link" # It's a symlink. Its target is not a dir. { RUN_CANONICALDIR="$(readlink -f "$RUN_DIR")" && [ "$RUN_CANONICALDIR" ] ; } || log_action_end_msg_and_exit 1 "Canonical path of the run directory could not be determined" # Create directory at the target mkdir "$RUN_CANONICALDIR" || log_action_end_msg_and_exit 1 "Error creating directory $RUN_CANONICALDIR" fi # The resolvconf run directory now exists. if [ ! -d "${RUN_DIR}/interface" ] ; then mkdir "${RUN_DIR}/interface" || log_action_end_msg_and_exit 1 "Error creating directory ${RUN_DIR}/interface" fi # The interface directory now exists. We are done. return } wipe_runtime_directories() { # Delete files in the resolvconf run directory (target) but not the directory itself [ -d "$RUN_DIR" ] || return rm -f "$RUN_DIR"/resolv.conf rm -f "$ENABLE_UPDATES_FLAGFILE" rm -f "$POSTPONED_UPDATE_FLAGFILE" rm -rf "${RUN_DIR}/interface/*" return } case "$1" in start) # The "start" method should only be used at boot time. # Don't run this on package upgrade, for example. log_action_begin_msg "Setting up resolvconf" # Wipe runtime directories in case they aren't on a tmpfs wipe_runtime_directories # Create runtime directories in case they are on a tmpfs create_runtime_directories # Request a postponed update (needed in case the base file has content). :> "$POSTPONED_UPDATE_FLAGFILE" || log_action_end_msg_and_exit 1 "failed requesting update" # Enable updates and perform the postponed update. resolvconf --enable-updates || log_action_end_msg_and_exit 1 "failed to enable updates" log_action_end_msg_and_exit 0 ;; stop) # The "stop" method should only be used at shutdown time. log_action_begin_msg "Stopping resolvconf" resolvconf --disable-updates || log_action_end_msg_and_exit 1 "failed to disable updates" log_action_end_msg_and_exit 0 ;; restart) log_action_begin_msg "Restarting resolvconf" resolvconf --enable-updates || log_action_end_msg_and_exit 1 "failed to enable updates" log_action_end_msg_and_exit 0 ;; reload|force-reload) resolvconf -u || log_action_end_msg_and_exit 1 "failed to update" exit 0 ;; enable-updates) resolvconf --enable-updates || log_action_end_msg_and_exit 1 "failed to enable updates" exit 0 ;; disable-updates) resolvconf --disable-updates || log_action_end_msg_and_exit 1 "failed to disable updates" exit 0 ;; status) if resolvconf --updates-are-enabled ; then log_success_msg "resolvconf updates are enabled" else log_failure_msg "resolvconf updates are disabled" fi exit 0 ;; *) echo "Usage: /etc/init.d/resolvconf {start|stop|restart|reload|force-reload|enable-updates|disable-updates|status}" >&2 exit 3 ;; esac # Don't reach here exit 99