Linux anchor 4.4.0-210-generic #242-Ubuntu SMP Fri Apr 16 09:57:56 UTC 2021 x86_64
Apache/2.4.18 (Ubuntu)
Server IP : 10.10.100.4 & Your IP : 216.73.217.150
Domains :
Cant Read [ /etc/named.conf ]
User : www-data
Terminal
Auto Root
Create File
Create Folder
Localroot Suggester
Backdoor Destroyer
Readme
/
usr /
lib /
python3 /
dist-packages /
cloudinit /
Delete
Unzip
Name
Size
Permission
Date
Action
__pycache__
[ DIR ]
drwxr-xr-x
2021-12-04 13:17
analyze
[ DIR ]
drwxr-xr-x
2021-12-04 13:17
cmd
[ DIR ]
drwxr-xr-x
2021-12-04 13:17
config
[ DIR ]
drwxr-xr-x
2021-12-04 13:17
distros
[ DIR ]
drwxr-xr-x
2021-12-04 13:17
filters
[ DIR ]
drwxr-xr-x
2021-12-04 13:17
handlers
[ DIR ]
drwxr-xr-x
2021-12-04 13:17
mergers
[ DIR ]
drwxr-xr-x
2021-12-04 13:17
net
[ DIR ]
drwxr-xr-x
2021-12-04 13:17
reporting
[ DIR ]
drwxr-xr-x
2021-12-04 13:17
sources
[ DIR ]
drwxr-xr-x
2021-12-04 13:17
__init__.py
0
B
-rw-r--r--
2021-03-19 15:37
apport.py
4.08
KB
-rw-r--r--
2021-03-19 15:37
atomic_helper.py
1.33
KB
-rw-r--r--
2021-03-19 15:37
cloud.py
3.15
KB
-rw-r--r--
2021-03-19 15:37
cs_utils.py
3
KB
-rw-r--r--
2021-03-19 15:37
dhclient_hook.py
2.48
KB
-rw-r--r--
2021-03-19 15:37
dmi.py
5.63
KB
-rw-r--r--
2021-03-19 15:37
ec2_utils.py
8.75
KB
-rw-r--r--
2021-03-19 15:37
event.py
450
B
-rw-r--r--
2021-03-19 15:37
features.py
2.03
KB
-rw-r--r--
2021-03-19 15:37
gpg.py
3.35
KB
-rw-r--r--
2021-03-19 15:37
helpers.py
15.71
KB
-rw-r--r--
2021-04-21 00:05
importer.py
1.38
KB
-rw-r--r--
2021-03-19 15:37
log.py
4.33
KB
-rw-r--r--
2021-03-19 15:37
netinfo.py
18.12
KB
-rw-r--r--
2021-03-19 15:37
patcher.py
1.23
KB
-rw-r--r--
2021-03-19 15:37
persistence.py
2.54
KB
-rw-r--r--
2021-03-19 15:37
registry.py
1.01
KB
-rw-r--r--
2021-03-19 15:37
safeyaml.py
1.19
KB
-rw-r--r--
2021-03-19 15:37
serial.py
1.15
KB
-rw-r--r--
2021-03-19 15:37
settings.py
1.89
KB
-rw-r--r--
2021-03-19 15:37
signal_handler.py
1.8
KB
-rw-r--r--
2021-03-19 15:37
simpletable.py
1.85
KB
-rw-r--r--
2021-03-19 15:37
ssh_util.py
13.37
KB
-rw-r--r--
2021-03-19 15:37
stages.py
38.54
KB
-rw-r--r--
2021-03-19 15:37
subp.py
13.06
KB
-rw-r--r--
2021-03-19 15:37
temp_utils.py
2.87
KB
-rw-r--r--
2021-03-19 15:37
templater.py
6.4
KB
-rw-r--r--
2021-03-19 15:37
type_utils.py
726
B
-rw-r--r--
2021-03-19 15:37
url_helper.py
21.74
KB
-rw-r--r--
2021-03-19 15:37
user_data.py
14.3
KB
-rw-r--r--
2021-03-19 15:37
util.py
78.86
KB
-rw-r--r--
2021-03-19 15:37
version.py
599
B
-rw-r--r--
2021-04-21 00:06
warnings.py
3.83
KB
-rw-r--r--
2021-03-19 15:37
Save
Rename
# This file is part of cloud-init. See LICENSE file for license information. """ Feature flags are used as a way to easily toggle configuration **at build time**. They are provided to accommodate feature deprecation and downstream configuration changes. Currently used upstream values for feature flags are set in ``cloudinit/features.py``. Overrides to these values (typically via quilt patch) can be placed in a file called ``feature_overrides.py`` in the same directory. Any value set in ``feature_overrides.py`` will override the original value set in ``features.py``. Each flag should include a short comment regarding the reason for the flag and intended lifetime. Tests are required for new feature flags, and tests must verify all valid states of a flag, not just the default state. """ ERROR_ON_USER_DATA_FAILURE = True """ If there is a failure in obtaining user data (i.e., #include or decompress fails) and ``ERROR_ON_USER_DATA_FAILURE`` is ``False``, cloud-init will log a warning and proceed. If it is ``True``, cloud-init will instead raise an exception. As of 20.3, ``ERROR_ON_USER_DATA_FAILURE`` is ``True``. (This flag can be removed after Focal is no longer supported.) """ ALLOW_EC2_MIRRORS_ON_NON_AWS_INSTANCE_TYPES = False """ When configuring apt mirrors, if ``ALLOW_EC2_MIRRORS_ON_NON_AWS_INSTANCE_TYPES`` is ``True`` cloud-init will detect that a datasource's ``availability_zone`` property looks like an EC2 availability zone and set the ``ec2_region`` variable when generating mirror URLs; this can lead to incorrect mirrors being configured in clouds whose AZs follow EC2's naming pattern. As of 20.3, ``ALLOW_EC2_MIRRORS_ON_NON_AWS_INSTANCE_TYPES`` is ``False`` so we no longer include ``ec2_region`` in mirror determination on non-AWS cloud platforms. If the old behavior is desired, users can provide the appropriate mirrors via :py:mod:`apt: <cloudinit.config.cc_apt_configure>` directives in cloud-config. """ try: # pylint: disable=wildcard-import from cloudinit.feature_overrides import * # noqa except ImportError: pass